Requirements 3.0

From SubjectsPlus
Revision as of 13:33, 8 August 2015 by Agdarby (Talk | contribs) (Created page with "* '''PHP >= to 5.3'''. The new namespaces we are using require PHP version greater than/equal to 5.3. Sorry! * '''MySQL''' --anything over 4 should be ok * '''Web server'''...")

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search
  • PHP >= to 5.3. The new namespaces we are using require PHP version greater than/equal to 5.3. Sorry!
  • MySQL --anything over 4 should be ok
  • Web server -- usually Apache, but some people have SubjectsPlus running on IIS
  • JavaScript enabled for the admin to work properly.

If you run into any missing/weird functionality, check that the following extensions are enabled for PHP:

  • cURL
  • MySQL
  • mbstring (not necessary, but you'll need to tweak header.php without this)
  • simplexml (for reading RSS feeds)
  • json (some data is stored as json)
  • gettext (only if you need internationalization, aka translations)
  • gd (image resizing--notably for headshots and generation of video thumbnails)


Some Helpful Install Commands

Debian/Ubuntu

sudo apt-get install mysql-server mysql-client apache2 php5 libapache2-mod-php5 php5-mysql php5-curl php5-gettext php5-gd

Red Hat/Fedora/Scientific Linux

sudo yum install mysql mysql-server httpd php php-mysql php-gd php-xml php-mbstring